Jesus 'n Jim
A PC and somewhat Mac oriented site with Software and Repair Info and How-To's on Using Computers

April 3 Windows Update causes blue screen (BSOD)


 

I have a Dell 4600 computer with Roxio Easy Media Creator 9 Suite & Sonic RecordNow installed. a couple of months ago after installing this package Dell's Service Advisor-type application in the system tray advised me to get the dell-approved Sonic DLA patch. Sonic DLA is a component of Roxio that enables the burner to look like a drive letter, and is similar in function to Nero's InCD I think. I have had troubles with Sonic DLA in the past with crashes & incompatibility with older roxio products, but I haven't had any troubles of late since this package was installed - it removed dell's installed Sonic application & upgraded Sonic DLA.

On April 3, 2008, I got a windows update KB925902 down the wire which caused a problem and I think updated c:\windows\system32\dla\tfsnifs.sys to a file dated 3/18/2007 (used to be dated 2004) - a "Security Update" to Windows XP. And then requested to restart my machine. My system would not boot after that. It bluescreened before it got to the logon screen, consistently with the following:

tfsnifs.sys stop 0000007e(c0000005,edb7ea4e,f7b6cb18,f7b6c814)
addr edb7ea4e base at edb72000 datestamp 419a571a7

I could not do anything in safe mode because the keyboard was disabled. my only recourse was a system rescue cd that allows NTFS read/write access or supports NTFS-3g such as the Ultimate Boot (ubcd4win) cd or System Rescue cd. I went in and renamed the file to a harmless tfsnifs.sy instead. then my system could boot. I then went into the control panel, add/remove programs, Sonic DLA and clicked remove. it gave me the choice to repair or remove, and I chose repair. this put the files back to their original state.

see post, microsoft blog.


There is a microsoft kb article 975070 describing a somewhat similar problem and includes some sort of fix, but I am sure you would have to apply it immediately after getting the update before rebooting (they didn't say that!). I don't know if that fixes this problem or not, but this also applies to Dell computers, though it doesn't say so.